Google Login
Don’t buy Joying Car Head Units:
Some of the car owners, including me, have purchased and installed Chinese Joying Head Unit (in various screen versions 8-9-10”). Some others are thinking about purchasing one. It is relatively inexpensive, has many functions (GPS, Rear camera, Phone, Remote, etc.) and the variety of applications can be installed. I owned it for three years and enjoyed it very much... Initially… But:
1. Recently many owners of Joying head units (HU) lost their ability to connect to Google applications (Google Maps for example). After downloading the upgrade provided by Joying tech support a number of owners reported that their Google Play Store account was hacked and unauthorized purchases and activities were recorded (see for example:
2. This HU has very bad radio sensitivity. I lost reception of more than half of local FM stations. Tried few antenna amplifiers, new antenna – nothing helps. The same problem was reported by other owners of Joying units.
3. If you restarted the unit with factory reset, “Easy Connect” application stops working and manufacture refuses to restore its functionality. According to Joying customer support “Easy Connect” isn’t supported by Joying and isn’t compatible with most of Joying models, in spite it is preinstalled by manufacturer. Of course, you can install other phone mirror applications like Android Auto, but with lost connectivity to Google Play store now it is problematic.
4. Depending upon the model it is hard or totally impossible to copy files from USB flash drive to device.
5. In spite it is an Android machine, some of the Android settings are removed. It is especially hard to read the small font in the maps and you cannot enlarge it because, the Settings-Accessibility-Font Size gives you no choices at the end.
6. The connector between processor and monitor isn’t designed for the car applications and after few months of usual driving vibrations the screen started flickering. I have ordered and replaced already one connecting cable, now the new one is failing again.
7. Very rude and unprofessional customer service at .
This is the citation from their answer to my request for help with firmware update after lost connectivity to Google: “Since your head unit purchased on aliexpress. please contact the support on aliexpress. they will help you.One order will be followed by one colleague. otherwise, the information will be mess. Hope you are well-understanding.”
The response from aliexpress Joying official store I bought HU from:
“Hi dear friend, I am sorry to hear that , but our store have not firmware for your car radio now , maybe you can try to reset the car radio”
Translated from Chinese that means: “We screwed you. You are on your own”. But maybe I am lucky. At least my account wasn’t hacked. I just wasted only $330 for Joying product that has little functionality now.
Keep my story in mind when after reading Joying commercial you start enthusiastically thinking about purchasing of their products.
(03-04-2021, 10:08 AM)admin Wrote:  
(02-26-2021, 12:46 AM)Rattler196 Wrote:  I cant add a google account to my new Android 10 head unit. It wont let me login to Google or any of the Google apps. Even when I go to add account info through settings instead of an app it just does the "Checking Info" loop and opens the google login page for about 1/2 second where you put in your email and password, and then it closes and goes back to the sign in page. Ive done a reset on it numerous times, it has strong wifi signal, but still wont let me add a google account to the device. this is getting frustrating! Ive cleared out google play data, and updated all the apps several times. HELP!

Please try to reset the Google play sevice app and then flashing the firmware again.

I've tried, it doesn't work.
Try reaching support, no answer, posted a new threat about the problem, no replies. thanks joying, great customer service!

(03-05-2021, 03:21 PM)Hesediel Wrote:  
(03-05-2021, 11:34 AM)Bipbip86 Wrote:  With the firmware?
Could you tell us a little more about this firmware and the procedure?
Thank you

Download the firmware from there

I have the 7 inch tablet, version UQS03N4G 1024x600

So look your tablet inch and resolution.

I downloaded the zip firmware, the first one in my case.

Unzip the file on a empty usb pendrive.

Go to the tablet, then settings and search the apps menu.
Looked for google play services
I forced the app stop
Then clear cache and storage. After that immediately i connected the pendrive.
The table recognized the firmware in automatic, and asked for flash. I said yes...just waited 5 minutes and after the flash and reboot i was able to put the Google account

I've tried, it doesn't work.